PKGBUILDs/mingw-w64-nim-git/0002-Always-look-in-unix-pa...

14 lines
476 B
Diff

diff --git a/compiler/nimconf.nim b/compiler/nimconf.nim
index 808159b..12e0b49 100644
--- a/compiler/nimconf.nim
+++ b/compiler/nimconf.nim
@@ -221,7 +221,7 @@ proc getSystemConfigPath(filename: string): string =
# the UNIX way)
let p = getPrefixDir()
result = joinPath([p, "config", filename])
- when defined(unix):
+ when true:
if not existsFile(result): result = joinPath([p, "etc", filename])
if not existsFile(result): result = "/etc/" & filename