32 lines
833 B
Diff
32 lines
833 B
Diff
--- a/lib/wrappers/pcre.nim
|
|
+++ b/lib/wrappers/pcre.nim
|
|
@@ -312,12 +312,7 @@
|
|
|
|
when not defined(usePcreHeader):
|
|
when hostOS == "windows":
|
|
- when defined(nimOldDlls):
|
|
- const pcreDll = "pcre.dll"
|
|
- elif defined(cpu64):
|
|
- const pcreDll = "pcre64.dll"
|
|
- else:
|
|
- const pcreDll = "pcre32.dll"
|
|
+ const pcreDll = "libpcre-1.dll"
|
|
elif hostOS == "macosx":
|
|
const pcreDll = "libpcre(.3|.1|).dylib"
|
|
else:
|
|
--- a/lib/wrappers/sqlite3.nim
|
|
+++ b/lib/wrappers/sqlite3.nim
|
|
@@ -11,12 +11,7 @@
|
|
{.push styleChecks: off.}
|
|
|
|
when defined(windows):
|
|
- when defined(nimOldDlls):
|
|
- const Lib = "sqlite3.dll"
|
|
- elif defined(cpu64):
|
|
- const Lib = "sqlite3_64.dll"
|
|
- else:
|
|
- const Lib = "sqlite3_32.dll"
|
|
+ const Lib = "libsqlite3-0.dll"
|
|
elif defined(macosx):
|
|
const
|
|
Lib = "libsqlite3(|.0).dylib"
|