Compare commits

...

3 Commits

Author SHA1 Message Date
Connor Olding c647c94e6f update ffmpeg and mpv 2019-12-23 06:19:01 -08:00
Connor Olding 88fd9b13f5 fix ffmpeg versioning
ffmpeg, extracted from a tarball,
was pulling its version from the parent mxe git directory tree,
so this patch simply removes the invocations of git.
2019-12-23 02:39:05 -08:00
Connor Olding 90b10cc3d6 update nim to 1.0.4 2019-12-23 02:15:18 -08:00
4 changed files with 29 additions and 6 deletions

View File

@ -6,7 +6,7 @@ license=('MIT')
options=('!emptydirs')
provides=('nim' 'nimble')
conflicts=('nim' 'nimble')
pkgver=1.0.0
pkgver=1.0.4
_csources=0.20.0
_nimble=0.11.0
pkgrel=1
@ -19,7 +19,7 @@ source=(nim-${pkgver}.tar.gz::https://github.com/nim-lang/Nim/archive/v${pkgver}
'0002-Always-look-in-unix-paths.patch'
'0003-Check-lib-nim-subdirectory.patch'
'0004-Use-mingw64-dlls.patch')
sha256sums=('6d93d25da6b5ef4e0223acb1f1abadf06be1019a8137491ddc7c6fa030e638c3'
sha256sums=('a3de1c63e70ede5de98d707397f461944732d9b127b41ed35983698b7a8677c9'
'5e6fd15d90df1a8cb7614c4ffc70aa8c4198cd854d7742016202b96dd0228d3c'
'a31d06128f3d1014d68297aa5cd264023d202cae74746d78ba84e335af3399d2'
'3010acbe7769ea214dd51f5889e3a26b44925001905deb04b060beaede2578f4'

View File

@ -0,0 +1,23 @@
--- a/ffbuild/version.sh
+++ b/ffbuild/version.sh
@@ -2,20 +2,6 @@
# Usage: version.sh <ffmpeg-root-dir> <output-version.h> <extra-version>
-# check for git short hash
-if ! test "$revision"; then
- if (cd "$1" && grep git RELEASE 2> /dev/null >/dev/null) ; then
- revision=$(cd "$1" && git describe --tags --match N 2> /dev/null)
- else
- revision=$(cd "$1" && git describe --tags --always 2> /dev/null)
- fi
-fi
-
-# Shallow Git clones (--depth) do not have the N tag:
-# use 'git-YYYY-MM-DD-hhhhhhh'.
-test "$revision" || revision=$(cd "$1" &&
- git log -1 --pretty=format:"git-%cd-%h" --date=short 2> /dev/null)
-
# Snapshots from gitweb are in a directory called ffmpeg-hhhhhhh or
# ffmpeg-HEAD-hhhhhhh.
if [ -z "$revision" ]; then

View File

@ -3,8 +3,8 @@
PKG := ffmpeg
$(PKG)_WEBSITE := https://ffmpeg.org/
$(PKG)_IGNORE :=
$(PKG)_VERSION := 2dd71bf
$(PKG)_CHECKSUM := dc82919dfa4a0536bca6b45f68e0d4d31c613144e7582b7792445664630e8b9b
$(PKG)_VERSION := f09ae73
$(PKG)_CHECKSUM := 968fcaba54b5b245f477ba5236412cb690714327a28c65a5f2bee5d77ab67b96
$(PKG)_SUBDIR := $(PKG)-$($(PKG)_VERSION)
$(PKG)_FILE := $($(PKG)_VERSION).tar.gz
$(PKG)_URL := https://git.ffmpeg.org/gitweb/ffmpeg.git/snapshot/$($(PKG)_FILE)

View File

@ -3,8 +3,8 @@
PKG := mpv
$(PKG)_WEBSITE := https://mpv.io/
$(PKG)_IGNORE :=
$(PKG)_VERSION := 871900f
$(PKG)_CHECKSUM := e3fc50511876b26153c3abc12d272fa4e58c1ed9fff5da8b3e0d6e064f2f8364
$(PKG)_VERSION := d951a7f
$(PKG)_CHECKSUM := 2e3f5c6b796cdbf03996a62b236a452bb18623bf0d815f30617e6ecfc925f7a9
$(PKG)_GH_CONF := mpv-player/mpv/branches/master
$(PKG)_DEPS := cc ffmpeg fribidi lcms \
libarchive libass libdvdnav libdvdread libiconv \