fix ffmpeg versioning

ffmpeg, extracted from a tarball,
was pulling its version from the parent mxe git directory tree,
so this patch simply removes the invocations of git.
This commit is contained in:
Connor Olding 2019-12-23 02:36:03 -08:00
parent 90b10cc3d6
commit 88fd9b13f5

View File

@ -0,0 +1,23 @@
--- a/ffbuild/version.sh
+++ b/ffbuild/version.sh
@@ -2,20 +2,6 @@
# Usage: version.sh <ffmpeg-root-dir> <output-version.h> <extra-version>
-# check for git short hash
-if ! test "$revision"; then
- if (cd "$1" && grep git RELEASE 2> /dev/null >/dev/null) ; then
- revision=$(cd "$1" && git describe --tags --match N 2> /dev/null)
- else
- revision=$(cd "$1" && git describe --tags --always 2> /dev/null)
- fi
-fi
-
-# Shallow Git clones (--depth) do not have the N tag:
-# use 'git-YYYY-MM-DD-hhhhhhh'.
-test "$revision" || revision=$(cd "$1" &&
- git log -1 --pretty=format:"git-%cd-%h" --date=short 2> /dev/null)
-
# Snapshots from gitweb are in a directory called ffmpeg-hhhhhhh or
# ffmpeg-HEAD-hhhhhhh.
if [ -z "$revision" ]; then